
Troubleshooting Video Problems 
 

Q.  What can I do about video problems, such as if green or pink lines appear on the video, flickering or choppy video, the Player stops 

responding when playing video, and so on? 

A.  Check for updates for the driver software for your graphics adapter and Microsoft DirectX from Windows Update. 
If that doesn't solve the problem, turn down (or turn off) video acceleration by doing the following: 

1.  On the Tools menu, click Options, and then click the Performance tab. 
2.  In the Video acceleration area, move the slider to turn down or turn off video acceleration. 

 

Q.  Why does the Player stop playing in full-screen mode? 

A.  Make sure your screen saver doesn't move the Player out of full-screen mode when the screen saver turns on. Also, turning off the 
Enable full-screen mode switch feature might solve the problem. To do this: 

1.  On the Tools menu, click Options, and then click the Performance tab.
2.  Click Advanced. 
3.  Clear the Enable full-screen mode switch check box. 

Note that for Windows XP, full-screen controls disappear if you stop moving the mouse and the cursor is not hovering over the 
controls. If you want the controls to disappear more quickly, you can clear the Display full-screen controls check box (which is 
also located on the Advanced dialog box). Or you can use the TweakMP Powertoy for Windows XP from WMPlugins.com to 
adjust full-screen settings. 

Q.  Why doesn't my video appear unless I maximize the window, put another window in front of it, or do something similar? 

A.  There is a problem with the driver software for your graphics adapter. Check for updated drivers from Windows Update. 
If that doesn't solve the problem, turn down (or turn off) video acceleration by doing the following: 

1.  On the Tools menu, click Options, and then click the Performance tab. 
2.  In the Video acceleration area, move the slider to turn down or turn off video acceleration. 

 

Q.  Video isn't playing correctly when I play a playlist. How can I fix the problem? 

A.  If you find that a video disappears or turns purple and green about 20 seconds before it stops playing, or that video for every file in 
the playlist isn't displayed, turn off overlays by doing the following: 

1.  On the Tools menu, click Options, and then click the Performance tab.
2.  Click Advanced. 
3.  Clear the Use overlays check box. 

If the problem continues, try turning off the video mixing renderer (VMR). You can turn off the VMR by clearing the Use video 
mixing renderer check box (also located on the Advanced dialog box). 

Q.  Why does the Player display a visualization instead of the video when I play an .avi file? 

A.  The video codec that is required to decode and display the video may not be installed on your computer. For example, if you are 
trying to play a file that was encoded using the DivX video codec and you do not have that codec installed on your computer, you 
will likely hear the audio portion of the file, but you won't see the video. For information about finding and downloading codecs, see 
the Using codecs FAQ. 



Q.  Why does the Player display a visualization instead of the video (or give an error message) when I try to play an .mpg or .mpeg file? 

A.  The MPEG-2 decoder (also called a DVD decoder) that is required to decode and display the video in your file may not be installed 
on your computer. For more information about installing an MPEG-2 decoder on your computer, see DVD Decoder Plug-ins. 

Q.  How do I get the Player to play in full-screen mode on my second monitor? 

A.  The Player can only play in full-screen mode on the primary monitor. For more information about changing your primary monitor, 
see Windows Help and Support. 

Q.  When I try to play my .avi file, why do I receive a message saying "Not enough storage is available to complete this operation"? 

A.  The file you are trying to play might be corrupted. It is recommended that you contact the content creator to obtain a new file. 

Q.  How do I access multiple MPEG audio channels? 

A.  For Windows Media Player 9 Series or later, you can set these options by using the Audio and Language Tracks command that is 
available on the Play menu. For Windows Media Player 7 and Windows Media Player for Windows XP, simply play the first audio 
channel. For Windows Media Player 6.4, you can select the audio channel by clicking the Properties command on the File menu. 

Q.  Can I change video one frame at a time while viewing it in the Player? 

A.  Yes, by doing the following: 
1.  On the View menu, click Enhancements, and then click Play Speed Settings.
2.  Click the Next frame or Previous frame button. 

 

Q.  How do I stop video from flickering? 

A.  This problem is most likely related to needing a driver software update for your graphics adapter. For more information, see What 
can I do about video problems? 

Q.  Why can't I play an MP3 file? 

A.  If you receive a message that contains error codes 0xC00D0BB8 or 0xC00D1199 when trying to play an .mp3 file, the problem 
might be because the file has a compressed or unsynchronized ID3 header that the Player does not support for security reasons. For 
more information about unsynchronized ID3 headers, in the Microsoft Knowledge Base, see article 814129, "Error in Windows 
Media Player 9 Series When You Play Specific MP3 Files." 
For compressed headers or other ID3v2 data, you can use a tag editing program to remove the information. For example, you can 
use the Advanced WMA Workshop, available from LitexMedia. 

Q.  Why do I hear audio distortion while playing an MP3 file? 

A.  If you hear audio distortion when playing an .mp3 file, find the file Ctmp3.acm on your computer and rename it to Ctmp3.bak. The 
Player isn't fully compatible with the Ctmp3.acm file, which is a Creative PlayCenter MP3 decoder. 
 



Q.  I can't get crossfading to work. What can I do? 

A.  If crossfading doesn't seem to work, try the following: 
• Verify that your operating system is Windows XP and that you are using Windows Media Player 9 Series or later. 
• Be sure you are playing Windows Media Audio (WMA) or MP3 files that are stored on your computer or on a data or 

HighMAT CD, rather than playing songs directly from an audio CD. Crossfading does not work with audio CDs. 
• Test crossfading with songs that were ripped at the same time. Crossfading might not work if the files have different 

sampling rates or bit depths, different numbers of audio channels, or if any of the files contain other kinds of streams in 
addition to audio (such as video, script, or HTML). 

• Check that you are playing files that were ripped with the same copy protection setting. For crossfading to work, the files 
you are playing must either all have copy protection turned on, or they must all have copy protection turned off. 

• Test songs that have reasonably high volume at the beginning and at the end of the song, because crossfading reduces the 
volume during those sections. 

• Move the overlap slider to the far right (for the maximum amount of overlap) for the best chance of hearing the overlap on 
a wide variety of songs. 

 

Q.  When I click a link to a .midi or .wav file on a Web page, the file doesn't play unless I right-click the link, click "Save target as", and 

then save it to my desktop. How can I avoid this? 

A.  Do the following: 
1.  On the Tools menu, click Options, and then click the File types tab.
2.  Clear the MIDI file (midi) check box, and then click Apply. 
3.  Select the MIDI file (midi) check box, and then click OK. 

 

Q.  Why is seeking disabled when I play files? 

A.  There are several possible reasons: 
• If you're playing a file that is being streamed from a Windows Media server, seeking is probably not enabled because the 

file was not indexed. 
• If you're playing the file from a Web server, seeking is not supported. 
• If you're playing the file on your computer, the file may not be indexed. Files can be indexed by using Windows Media 

File Editor, a utility that is included with Windows Media Encoder 9 Series. Note that Windows Media files are indexed by 
default. 

• If you are using Windows Media Player 6.4, seeking is not available. Instead, you can use the position slider to adjust the 
position in the file. 

 

Q.  How do I make Windows Media Player the default player for a file type? 

A.  You can make Windows Media Player the default player for a number of file types (formats). You must be logged on as an 
administrator or a member of the Administrators group to change the file types that the Player will play by default. The procedure 
varies depending on which version of the Player you are running.  

  Windows Media Player for Windows XP or later 
1.  On the Tools menu, click Options, and then click the File Types tab. 
2.  Select the check box of the file types you want to play in Windows Media Player. 

The Player may not be able to play a file, even though you have selected its file type. This can occur if the file uses a 
codec that is not installed on your computer. For information about codecs, including how to download them, see the 
Using codecs FAQ. 



The Player can play other file types but cannot be set as the default player for them. For more information about all of 
the file types that the Player supports, see Windows Media Player multimedia file formats. 

3.  Clear the check box of the file types you do not want to play in Windows Media Player. 
Clearing the check box next to a file type restores the file type association to the previous default player, if one was 
specified. If no default player was previously specified and you try to play a file, a Windows dialog box will be displayed 
so that you can select the program you want to play the file. 

4.  If a check box appears dimmed, the Player has only partial ownership of the file type. Multiple file name extensions are 
assigned to the file type, but the Player only plays some of those extensions by default. To give the Player full ownership 
of a file type, double-click the dimmed check box. 

  Windows Media Player 7 
1.  On the Tools menu, click Options, and then click the Format tab. 
2.  Select the check box of the file types you want to play in Windows Media Player.

Note that if you install other players on your computer, they may interfere with your Windows Media Player file types settings. For 
more information about setting file type ownership in other players, see the documentation that came with those programs. 

Q.  What's the difference between the .asf, .wma, and .wmv file name extensions? 

A.  The .wma file name extension is used for Windows Media Audio (WMA) files that contain audio compressed with one of the 
Windows Media Audio codecs. 
The .wmv file name extension is used for Windows Media Video (WMV) files that contain both audio and video compressed with 
the Windows Media Audio and Video codecs. 
The .asf file name extension is used for content that includes audio only or both audio and video. The content in an .asf file could be 
encoded by a variety of different codecs, including Windows Media Audio and Video codecs. For more information about the 
Windows Media and Advanced Streaming Format (ASF) file formats, see Windows Media Format. For more information about 
codecs, see the Using codecs FAQ. 

Q.  Why does the Player keep crashing? 

A.  The Player interacts with many system components, including drivers, codecs, and DirectShow filters. It is possible that the Player is 
not responding because of a faulty or incompatible component from another provider, such as a codec pack. (Examples include the 
DivXNetworks Nimo, Tsunami, and K-Lite codec packs, the SoftRom.Net ACE Mega, and the All in 1 codec packs.) 
Incompatibilities are known to exist with some of the components in the codec packs. The incompatibilities can cause serious 
playback issues in Windows Media Player and other players, can lead to system corruption, and can make it difficult for Microsoft 
Product Support Services to diagnose and troubleshoot playback problems. For more information about resolving this problem, see 
the Using codecs FAQ. 
To protect the security of your computer, be sure to only download programs, codec packs, and other items from sources that you 
trust. To learn more about security, see the Windows Media Player 11 or Windows Media Player 10 security statement. 

Q.  My question isn't answered in this FAQ. What can I do? 

A.  If you do not find an answer to your question in this FAQ, try the following resources: 
• See Windows Media Player Help. To access Help, start Windows Media Player and then press F1. 
• Submit a question to the Media Advice column.  
• For other Windows Media FAQs, including other versions of the Player, see Frequently asked questions about Windows 

Media.  
• To find additional support and troubleshooting resources, see Troubleshooting Windows Media Player.  
• Submit a question to the Windows Media Player newsgroup. Please note that the newsgroup is maintained by a community 



of knowledgeable users offering peer-to-peer assistance. It is not an official Microsoft technical support resource. As such, 
Microsoft cannot guarantee that your question will be answered. When you ask a question on the newsgroup, be as specific 
as possible. For example, be sure to include the following basic information: 

• Windows Media Player version. (On the Help menu, click About Windows Media Player.) For example, the 
version might be 10.00.00.xxxx.  

• Windows operating system version. (Click Start, right-click My Computer, and then click Properties.) In your 
question, include the full version name (for example, Windows XP Professional with Service Pack 2).  

• The task that you were trying to accomplish prior to encountering the problem. 
• If an error message is displayed, note the error message text. (For example, it might say "Windows Media Player 

has encountered an unknown error.") 
• If an error message is displayed, note the error message ID number (for example, "C00D11CD"). You can 

determine the ID number by clicking the Web Help or More Information button when the error message is 
displayed.  

• If the problem only occurs when you use a particular file, Web link, or URL, provide details about that item. 
  

Q.  How do I find information about error messages? 

A.  To find the error code identification number for a particular error message, on the error message, do one of the following: 
• Click the Web Help button. A Web page is displayed. The specific error code identification number is mentioned in the 

first sentence (for example, C00D1197).  
• Click the More Information button. A Help topic is displayed. The specific error code identification number is mentioned 

in the title or at the bottom of the topic (for example, C00D1197).  
For information about Windows Media Player error messages, see Troubleshooting Windows Media Player Error Messages.  

 


